Legfontosabb Pc És Mac Az e-mailek megkülönböztetik a kis- és nagybetűket?

Az e-mailek megkülönböztetik a kis- és nagybetűket?



Nagy a zavar, hogy az e-mail címek megkülönböztetik-e a kis- és nagybetűket, vagy sem. Egyesek szerint igen, míg mások azt állítják, hogy nem. Szóval, kinek van igaza? Ebben a cikkben megvizsgáljuk, hogy az e-mail címek megkülönböztetik-e a kis- és nagybetűket.

Az e-mailek megkülönböztetik a kis- és nagybetűket?

Mitől lesz e-mail cím?

Az e-mail cím három részből áll - a helyi részből (más néven felhasználónévből), a @ jelből és a tartományból. Minden résznek megvan a maga szerepe, és a saját szabályrendszere alá tartozik. Itt egy rövid áttekintés.

A szabvány szerint az e-mail cím helyi része legfeljebb 64 karakter hosszú lehet, és korlátozott karakterkészletből állhat. Ide tartoznak a kis és nagybetűs latin ábécé betűi, a 0 és 9 közötti számok, a pont és a speciális karakterek. A speciális karakterek közé tartozik az [[email protected] # $% ^ & * () _- + = [] {} ~. A tartományrészhez @ jellel kapcsolódik.

A tartományrész legfeljebb 255 karakter hosszú lehet. Tartalmazhatja a latin ábécé betűit (kis- és nagybetűket egyaránt), 0 és 9 közötti számokat, valamint kötőjelet. A kötőjel nem tudja elindítani vagy befejezni a tartományrészt.

Nemzetközi szimbólumok is használhatók, bár erről később.

Megkülönbözteti a kis- és nagybetűket?

A helyes válasz erre a kérdésre igen és nem. Alapján RFC 5321 , az e-mail cím helyi része megkülönbözteti a kis- és nagybetűket. Ez azt jelenti, hogy elméletileg az [email protected] nem azonos az [email protected] -vel. Az e-mail szolgáltatók azonban szabadon kezelhetik a helyi részeket kis- és nagybetűk szempontjából.

Például az [email protected], az [email protected] és az [email protected] elméletileg különböző e-mail címek. Könnyű belátni, hogy ez hogyan okozhat problémákat és ronthatja a felhasználói élményt, ha egy levelező szerver úgy dönt, hogy a helyi részeket kis- és nagybetűkkel kezeli. Ezért sok szolgáltató kis- és nagybetűkkel kezeli az e-mail cím helyi részét.

mit esznek a teknősök a minecraftban

Ami a tartományrészt illeti, RFC 1035 előírja, hogy mindig nem érzékeny a kis- és nagybetűkre. Ez azt jelenti, hogy kisbetűvel, nagybetűvel vagy a kettő bármely kombinációjával megírhatja, és az e-mail ugyanazon a címen lesz. A gyakorlatban az [email protected], az [email protected] és az [email protected] azonos e-mail cím.

Gyakorlatban

Míg az e-mail címek csak részben különböztetik a kis- és nagybetűket, általában biztonságosnak tekinthetjük őket kis- és nagybetűkben. Minden nagyobb szolgáltató, például a Gmail, a Yahoo Mail, a Hotmail és mások, az e-mail címek helyi részeit kis- és nagybetűkkel kezelik. Ennek ellenére ellenőrizze annak az e-mail szolgáltatónak a szabályait, amellyel e-mailt szeretne létrehozni.

Összegezve az előző pontot, a fent említett RFC 5321 azt javasolja, hogy új e-mail címeket csak kis betűkkel hozzanak létre, hogy elkerüljék az esetleges zavart és kézbesítési problémákat.

Másrészt, ha barátodnak vagy kollégádnak van e-mail címe nagy- és kisbetűk kombinációjával, akkor célszerű úgy megírni, mint amikor e-mailt küld nekik. Ennek elmulasztása miatt az e-mail nem kerül kézbesítésre. Ez azonban nem jelent problémát olyan nagy e-mail szolgáltatókkal, mint a Gmail, a Yahoo Mail, a Hotmail és mások.

Ezenkívül a Gmail nem érzékeny az e-mail helyi részében található pontokra, amikor a felhasználói fiók azonosításáról van szó. Ez azt jelenti, hogy ha létezik [e-mail védett] fiók, akkor nem fog tudni regisztrálni [e-mail védett] vagy [e-mail védett]

Nemzetközivé válás

Eredetileg az e-mail címeket csak a latin ábécé betűivel, számokkal és korlátozott számú speciális ASCII karakterrel lehetett regisztrálni. Azonban a IETF (Internet Engineering Task Force) ezt követően szabályokat és szabványokat dolgozott ki a nemzetközi karakterek beillesztésére.

RFC6530 elsőként vonta be és szabályozta a nemzetközi karakterek használatát. RFC6531 kibővítették a szabályokat és szabványokat. Ezt követően a szabályokat és a szabványokat a RFC6532 és RFC6533 .

Most már regisztrálhat egy e-mail címet ábécék, karakterek és szkriptek széles választékával. A legelterjedtebbek között szerepelnek a diakritikus latin karakterek, a görög ábécé, a hagyományos kínai karakterek, a japán karakterek (hiragana, katakana és kandzsi), cirill ábécé, számos indiai írás, valamint egy sor más.

A nemzetközi e-mail címek felvétele és kompatibilitása szolgáltatónként eltérő. Még a legnagyobb szolgáltatók sem teljes mértékben kompatibilisek a nemzetközi címmel. Például a Google lehetővé teszi e-mail küldését nemzetközi címre, de nem engedélyezi annak létrehozását. Az Outlook 2016 hasonló funkcióval rendelkezik.

Következtetés

A domainnévtől eltérően az e-mail cím helyi része megkülönbözteti a kis- és nagybetűket. Ennek ellenére sok e-mail szolgáltató úgy dönt, hogy gyakorlati okokból figyelmen kívül hagyja a helyi rész kis- és nagybetűk közötti különbségét, és arra ösztönzi az embereket, hogy csak kisbetűs karaktereket tartalmazó e-maileket hozzanak létre.

Érdekes Cikkek

Szerkesztő Választása

Mi az a firmware?
Mi az a firmware?
A firmware egy hardvereszköz kis memórialapkájára telepített szoftver. A firmware lehetővé teszi a hardverek, például a kamerák és okostelefonok frissítését.
Fotó elhomályosítása a Snapseedben
Fotó elhomályosítása a Snapseedben
A Snapseed a Google ingyenes alkalmazása a fényképek szerkesztésére. Vannak, akik összehasonlítják ezt az alkalmazást az Instagram-szal, de ez csak rossz. Ez egy professzionális képszerkesztő alkalmazás, nagyszerű készlettel és sokféle effektussal. Színezhet
Windows kötegelt szkript az adatok biztonsági mentéséhez
Windows kötegelt szkript az adatok biztonsági mentéséhez
Azok a számítógép-felhasználók, akik fejlett Mac és Windows számítógépekkel nőttek fel, lehet, hogy nincsenek tisztában ezzel, de egyszer, nagyon régen, az összes személyi számítógépet parancssori felület segítségével vezérelték. Igen, az a nehézkes parancsdoboz a Windows rendszeren
Az összes e-mail exportálása az Outlookból
Az összes e-mail exportálása az Outlookból
Ha az üzenetek törlése nélkül kell helyet felszabadítania az Outlook-postafiókjában, érdemes tudnia, hogyan exportálhatja őket. Szerencsére az Outlookot úgy tervezték, hogy megfeleljen a különféle forgatókönyveknek, így exportálhatja e-mailjeit
Hogyan juthat el ingyenes szállításhoz a StockX segítségével
Hogyan juthat el ingyenes szállításhoz a StockX segítségével
A StockX egy online tőzsde különféle dolgokhoz, például órákhoz, cipőkhöz, kollekcióhoz stb. A regisztráció egyszerű, és azonnal elkezdhet vásárolni vagy eladni. A StockX gondoskodik az összes termék hitelesítéséről, így Ön rendelkezik a
A Spotify Premium mostantól három hónapig csak 99p-os - és a meglévő felhasználók a Black Friday előtt is pénzt takaríthatnak meg
A Spotify Premium mostantól három hónapig csak 99p-os - és a meglévő felhasználók a Black Friday előtt is pénzt takaríthatnak meg
A Spotify nem hívja ezt fekete pénteki ajánlatnak, de a 2017-es fekete pénteki ajánlatok közepén jobb pofon esik. 2017. november 20. és december 31. között bárki, aki feliratkozik a Spotify Premium szolgáltatásra
Töltse le az Australian Landscapes témát a Windows 10, 8 és 7 rendszerekhez
Töltse le az Australian Landscapes témát a Windows 10, 8 és 7 rendszerekhez
Az ausztrál tájak témája 10 kiváló minőségű képet tartalmaz az asztal díszítésére. Ezt a gyönyörű tematikus csomagot eredetileg a Windows 7 számára hozták létre, de Windows 10, Windows 7 és Windows 8 rendszerekben is használható. Az Ausztrál Tájak témához számos lélegzetelállító háttérkép tartozik, amelyek buja zöld mezőkre, fák ligeteire nyújtanak kilátást.